Inobitec DICOM Viewer

6.9. Saving and Opening Segmentation Projects and DTI Projects

____________________________________________________________________________________________

Functionality is available in a separate module which is activated in the Pro edition for an extra fee
____________________________________________________________________________________________

The DICOM Viewer allows for saving segmentation projects and DTI projects in a file. One project may contain structures and DTI data from different series, as well as source DICOM data. If a project was saved without source DICOM data, it cannot be opened without downloading the corresponding series first.

Save project PIC , Append to existing project PIC and Open project PIC buttons are assigned to the same project management button. Depending on the last action performed, the button may be represented as PIC , PIC or PIC . When you press the left side of the button, the last action will be performed. To select another action, click the arrow on the right side of the project management button (shown with the red frame in Fig. 6.16).



6.9.1 Saving a Project

To enable/disable the saving of source DICOM data, in the main menu, select Options->Settings...->Modules->3D reconstruction, then choose the Project tab and check/uncheck the Save DICOM data of series box. This option is activated by default.

6.9.2 Opening a Project with Source DICOM Data

When a project is opened, the DICOM Viewer shows it in the Volume Reconstruction or Multiplanar Reconstruction tab. To choose a default tab, in the main menu, select Options->Settings...->Modules->3D reconstruction, then choose the Project tab, and choose the 3D or MPR opening mode. The 3D mode is chosen by default.

To open a project containing source DICOM data, in the default tab, select the main menu File->Open project.... A window will pop up, in which you will have to choose the file containing the project for this series. Press Open to open the project or Cancel to cancel the action. In the default tab, you will see all the data saved in the file.

To open a part of the project and specify the tab in which it is to be opened, proceed as follows:

  1. In the main menu, select File->Open project.... A window will pop up, in which you will have to choose the file containing the project for this series. Press Open to open the project or Cancel to cancel the action. The dialog box shown in Fig. 6.17 will pop up.
  2. Choose the tab in which you want to open the project (3D or MPR).
  3. Choose the series for which you want to display the data. To do this, click the left mouse button to highlight the series in the Source series list and press the > button (number 1 in Fig. 6.17). The series will be included in the Selected series list.
  4. Repeat the previous step for all the series you need.
  5. To delete a series from the selected series list, highlight it by clicking the left mouse button on the Selected series list and press the < button (number 2 in Fig. 6.17).
  6. Click OK to open the project or Cancel to cancel the operation.



If the project does not contain any source DICOM data, when you attempt to open it, an error notification will pop up: Cannot find DICOM data in the project file. The procedure of opening projects without DICOM data is described in Section 6.9.3.

6.9.3 Opening a Project without Source DICOM Data

To open a project without source DICOM data, you first need to open the source data in the Volume Reconstruction or Multiplanar Reconstruction tab.

To open a project that does not contain any source data:

  1. Open the initial series for which the project was saved in the Volume Reconstruction or Multiplanar Reconstruction tab.
  2. Open the segmented structure panel by pressing the PIC button.
  3. Click the arrow on the right side of the project management button and choose Open project PIC . A window will pop up, in which you will have to choose the file containing the project for this series. CLick Open to open the project or Cancel to cancel the operation.

The segmented structures and DTI data for this series contained in the project are added to the segmented structure panel. When the project is opened for the second time, the data are added again without replacing the old data. When the structures are edited on the segmentation panel, the file contents are not changed. If the file contains several projects, the structures (DTI data) are only displayed for those series that are currently open in the tab.

6.9.4 Adding Data to the Existing Project

To add data to the existing project, click the arrow on the right side of the project management button and choose Append to existing project PIC . A window will pop up, in which you will have to choose the existing file. Click Open to add or Cancel to cancel the operation. If the file already contains a project for this series, you will see a warning: The project for this series has already been saved. Would you like to overwrite this project? To overwrite the project, click Yes, to cancel — click No. When a project is overwritten, the projects for the other series in the same file are not changed.

To save a project and avoid the loss of the data that have already been stored in the file:

  1. Open the project in the file. The segmentation results that were stored earlier will be presented on the segmentation panel together with the current results.
  2. Add data to the existing project. A dialog box will pop up: The project for this series has already been saved. Do you want to replace it Click Yes.

When you work with a fused series, the structures for all the layers are saved in the project, regardless of what layer has been chosen.